RSS

Emacsen for your Mac

22 Jan

UPDATE I have leopard now so I thought I would let you know about emacs on leopard. It doesn’t work; Emacs 22.1 will not build. I did a quick google search and found a blog post that talks a bit about it. According to this site Aquamacs will work on leopard and there is an unofficial patch witch will get emacs building. I’m working on building it right now (cross your fingers).

Lets face it Mac OS doesn’t have a good gui text editor; sure there is Textedit but it saves rtfs which are completely useless for any real work. What you need is Emacs. There are a few really good Emacsen out there for mac os. (they’re all really just Gnu Emacs in different packages.)

Aquamacs

Aquamacs is an aqua version of GNU Emacs. It has all the power of emacs but with a Mac OS like interface. Aquaemacs is a really good solution for someone who doesn’t already know how to use emacs and doesn’t necessarily want to learn how to learn the traditional way to use it. but wants the power of emacs.

Carbon Emacs

Carbon Emacs is just a binary distribution of GNU Emacs. If you know how to use Emacs and you are looking for a binary distribution, this might just be the Emacsen for you. I haven’t look at this one for a long time so it might have some specializations for Mac OS and I just forgot.

GNU Emacs

Emacs 22.1 has Carbon support so if you want Emacs and you don’t have a problem with building in from source I would definitely suggest going this route. Its really pretty easy. After you download and decompress emacs move to the directory in the terminal and type:

./configure –enable-carbon-app (should be dashdash, stupid wordpress)
make
sudo make install

As far as I know every option I’ve presented so far is carbon. Right now all this means is that you can’t get a 64-bit version and they won’t be able to use the new libraries apple introduced in leopard (aquamacs would likely be the only one that would want to). However, future versions of Mac OS might drop carbon all together, meaning Emacs will have to be ported to cocoa. I don’t think there will be a problem using any of these with leopard but I can’t guarantee that as I don’t have leopard myself.

I have to admit that I don’t often use Emacs on my mac. I have it installed and now that I’m getting more used to using it (I use it on Linux) I might start using it more on my mac. What I do use is smultron. It doesn’t have all of the power of Emacs but it is nice and I know it will work with leopard.

Don’t know much about emacs? check out the last post I on emacs for more information.

If I have forgotten your favorite Emacsen or just said something stupid let me know in the comments.

Advertisements
 
Leave a comment

Posted by on January 22, 2008 in apple, emacs

 

Tags: , , ,

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

 
%d bloggers like this: